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Who designed supercomputers in 1960s
at Control Data Corporation (CDC) ?

(A) Alan Turing

(B) Charles Babbage
(C) Tim Berners-Lee
(D) Seymour Cray

What differentiates second and third
generation of computers ?

(A) Microprocessor
(B) Vacuum tube

(C) Nano technology
(D) Artificial intelligence

Compact Disk (CD) is which type of
memory ?

(A) Primary Memory
(B) RAM

(C) ROM

(D) Secondary Memory

Bus in computer is

(A) Networking device

(B) Bunch of wires

(C) Another name for Motherboard
(D) Internal Memory

Which is NOT a software in following list ?
(A) OpenOffice (B) Microsoft
(C) DOS (D) Antivirus

Which is NOT a peripheral device ?
(A) Visual display unit
(B) Main Memory chip
(C) Modem
(D) Pen Drive
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87. U UeTINER Fil complexity Sfai{ere s &
(A) Teares
(B) FaRan
(C) AFUsEan
(D) &t
88. Computation logic ! foeeh 3T & visually
Teramn s g 7 7
(A) Fogert sifes
(B) it
(C) vame fo=
(D) VI HUTEH

89. THACHRIHA H (BABA) g STdA H T T 7
(A) 134272
(B) 132272
(C) 135272
(D) 135242

90. 4.77 MRS 37 10 ATMESS o 3eTelvl &
(A) 10 Tifd
(B) ST TAMTRT il
(C) F Tt Tf wufrftheryH

(D) STT HSRIT il

91. ¢ wiiet T ST foreew s qfém shear € e et
RS ?
(A) T fewh 0 3
(B) Tt oft feamew
(C) RAM
(D) ROM
DHC TS12-WM
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87.

88.

89.

90.

91.

Complexity of an algorithm represents its
(A) Performance

(B) Toughness

(C) Obscurity

(D) Correctness

Computation logic can be represented
visually by using

(A) Visual Basic

(B) Foxpro

(C) Flow chart

(D) VI editor

(BABA),¢ in hexadecimal is what in octal ?
(A) 134272
(B) 132272
(C) 135272
(D) 135242

4.77 Mhz and 10 Mhz are examples of
(A) I/O speed
(B) Data Transfer speed
(C) Computer clock speed specification

(D) Data storage speed

Boot Loader program which invokes

booting of the system is stored in
(A) Hard disc O track
(B) Any device
(C) RAM
(D) ROM
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92.

93.

94.

95.

96.

DHC TS12-WM

g1eT fommfa form & g0 skt ST HehaT B 7

(A) TR
(B) HereTe
(C) Trferrer

(D) =g AT

A= S 12,000 T931 & 3775k 72 AT =Ry |
JT

(A) TG ST

(B) Gefiq smer

(C) =feres uftsTrfere smenm
(D) SATI=TIh sTe

Ty EsTe o e § e 8 8 e e ©

(A) Tafir arfererret it ve=m

(B) Tt farsiwanatt o @t & st fHmior
(C) AT=ar FamT 3T Seed STqsie ahl 0T
(D) 3Tk Gt

relation ¥ attributes = T w1 T ST &
(A) JgEd
(B) ferft
(C) Z=ucd
(D) 3ohTS

table =T column ford & &7 H STHT ST 2 7
(A) =Od
(B) T
(C) s
(D) feuft

-17-

92.

93.

94.

95.

96.

Data inconsistency can be prevented by
preventing

(A) Redundancy

(B) Metadata

(C) Deadlocks

(D) Multiprogramming

Employee salary should not be greater
than Rs. 12,000. This is

(A) Integrity constraint
(B) Referential constraint
(C) Over-defined constraint

(D) Feasible constraint

Database Design includes the functions like
(A) ldentification of different tables
(B) Creation of fields with their attributes

(C) Creating validation rules and

database interrelationships

(D) All of the above

The number of attributes in relation is called
as its

(A) Cardinality
(B) Degree
(C) Tuples
(D) Entity

The column of a table is referred to as the
(A) tuple

(B) attribute

(C) entity

(D) degree
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97.  ACID T[0T 1 2 2 5 reliably 31 TR & | =&t
AR

(A) g
(B) ATUTfaraRat
(C) Tentieem

(D) Geed

98. HiaWyl H ‘DELE’ HTS JAINT fehart ST 2
(A) Tt SAfirerE ger & ford
(B) dTfetsht B2H & for
(C) et e gem & ford
(D) &M = for fearte fafea =

99. &M 3Thdl § AT user ST 2 7
(A) CREATE USER Susan;

(B) CREATE OR REPLACE USER

Susan;

(C) CREATE NEW USER Susan
DEFAULT;

(D) CREATE USER SusanIDENTIFIED
BY blue;

100. fr=Aferfaa | forad g 3 7 7
(A) Select*from EMP where EMPID =15;
(B) Select EMPID from EMP where
EMPID = 15;
(C) Select EMPID from EMP;

(D) Select EMPID where EMPID = 15

and LASTNAME = ‘Singh’;
DHC TS12-WM
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97.

98.

99.

100.

ACID is a set of properties that guarantee
that database transactions are processed
reliably. Here A stands for

(A) Access

(B) Atomicity
(C) Algorithm
(D) Affiliation

In FoxPro the command ‘DELE’ is used to
(A) Delete all records
(B) Delete table
(C) Delete marked records

(D) Mark the records for deletion

Which statement creates a new user in
ORACLE ?

(A) CREATE USER Susan;
(B) CREATE OR REPLACE USER

Susan;

(C) CREATE NEW USER Susan
DEFAULT;

(D) CREATE USER SusanIDENTIFIED
BY blue;

Which of the following statement contains

an error ?
(A) Select*from EMP where EMPID = 15;

(B) Select EMPID from EMP where
EMPID = 15;

(C) Select EMPID from EMP;

(D) Select EMPID where EMPID = 15
and LASTNAME = ‘Singh’;
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D0 00O
101.  foreht anferent # A1 Fiee foosht it F wa @ | 101.  Afield in a table can be taken as a foreign

foran s gepan afe key if
(A) a8 ot arfereptati § HiS[E ? (A) Itis present in all other tables
(B) I= Afgdm oM (B) It has unique values

(C) T® 311 ATerah § T Wreifirer Fsft 2 (C) Is a primary key in some other table
(D) foreft oft e7=r ferert § g 7t ©

(D) Is not present in any other table

. 102. File fragmentation means that a file
102.  IEA HHIIM 1 HATE & o Th Wigd

(A) e q I8 % ol 7, [ 7

(A) Is unusable until it is defragmented

(B) Has been compressed

B) Wt foharm a3
®) (C) lIs stored in noncontiguous locations
(C) RAM T SEaTd Tl § TR & in RAM
(D) fewr o T *hleq3r@ Tl § HUeHd 8 (D) Is stored in noncontiguous locations
. . ) in disk
103. SR I TEET o IR B THER T
TR | 103. Information about the structure of Database
(A) 22 Bz is stored in
S A) Data Fil
(B) T (A) Data File
. B) Data Dictionar
(©) 21 7 (B) y
. (C) Data Components
P EEEIES

(D) Data Model
104. 4 =il 91t T fewh Uk fodeh g wie §
2655 2% Jeeh ook H 125 Tl 3T Jcdsh Tl
T 512 W15¢H B, 3! TUEY (VRW) &rwal

104. Storage Capacity of a disk pack consisting
of 4 plates each having 2655 tracks having

125 sectors per track, each sector having

R 512 bytes is approx.
(A) 1GB (A) 1GB
(B) 1 MB (B) 1 MB
(C) 1TB (C) 1TB
(D) 1280 KB (D) 1280 KB
DHC TS12-WM -19- *
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105.

106.

107.

108.

109.

FraforRaa o 8 S -3 31 2 g e A fassH
! Iga Fd @ 7

(A) Master, FAT

(B) Slave, FAT

(C) Primary, Active

(D) Primary, NTFS

ST h1E I U e & fow 8 forew yem
FAT R, I 39 U o T d TefRia
FEHA ¢ |

(A) 32

(B) 64

(C) 256

(D) 1,024

I THIIH § T
(A) 3B FATEE

(B) SIS

(C) @ 551

(D) 3Th | ¥ HIE AL

Frefafaa & @ F-91 T8 9 Tehst g1
GEISIERASIR:ET

(A) ¥ A

(B) EXE st

(C) =€ wreed

(D) s wrset

Teh S&dTasT 1 YOS 37T 3TAT Id T HSH o
foru faeheu

(A) HH AR

(B) ¥t Wl

(C) g=m

(D) W H U IS A

DHC TS12-WM

105.

106.

107.

108.

109.

Which two terms identify a bootable
partition ?

(A) Master, FAT

(B) Slave, FAT

(C) Primary, Active

(D) Primary, NTFS

When a program assigns 8 bits to a pixel,
that pixel can display one of up to
colors.

(A) 32
(B) 64
(C) 256
(D) 1,024

Outlook Express is a
(A) E-mail client
(B) Browser
(C) Search engine

(D) None of the above

Which of the following cannot be removed
by Anti Virus Package ?

(A) SPAM mail
(B) EXE files
(C) Word files
(D) PDF files

The option for sending same document or
letter at different addresses is

(A) Form letters
(B) Mailmerge
(C) Printing

(D) None of the above
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110. A ThiE C$4 Tah 3T & 110. The cell reference C$4 is an example of

(A) T & fore fder Thim (A) Absolute reference to cell

(B) | o foTw wTviey {hid (B) Relative reference to cell

(C) "t o fore iz Thie (C) Mixed reference to cell

(D) ¥t o feq wme=1 Thid (D) Simple reference to cell

111. MS-EXCEL@@%@W%@[{H}@E@E 111. Afeature in MS-EXCEL helping in decision

T ol a1 gt de A T afEd % T making by observing the effect of change
ER o T A R e in conditions on one data set on another
MS-EXCEL e 2 | data set is called MS-EXCEL

(A) =Tt et (A) Data filter

(B) =rie (B) Charting

(C) =ore-3% sfctiem (C) What-if analysis

(D) =t flist (3hH)

(D) Data series

112, STaRIHE o STERT-3TAT &1 H e o shidl B
& foru forshed =1 @ foRa ST
I

(A) Format > Paragraph

112. Copying format of text to different areas of

document is done using option
(A) Format > Paragraph

(B) Format Painter (B) Format Painter

(C) Edit > Copy (C) Edit> Copy

(D) &t foram St gehat @ (D) Cannot be done

113. @Wﬁ@ﬁﬂﬁ?ﬁmﬁﬁ@m 113. To connect a text phrase in a document to
O %%ﬁg‘? ITTFE R | another document we use

(A) Insert > Bookmark (A) Insert > Bookmark

(B) Insert > Hyperlink (B) Insert > Hyperlink
(C) File > PageSetup > Link (C) File > PageSetup > Link
(D) Insert > Footnote (D) Insert > Footnote
DHC TS12-WM 21- *
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MS-EXCEL ® #gist ol 309 afvla & ferm
ST HFAT R ?
(A) MS-EXCEL H UTfthe STTeehe sl ST
(B) TR & B THS
(C) MS-EXCEL # facsmi ferifém am am-
T IMEhe FiSTT o HTEAH T T o oY
B I FHT

(D) ¥TTEehe o HIEAH | WIgT SR o BIE Tohs

114.

115.  MS-EXCEL 3 ashefie I # 39 ot o fordl

AT sTeneAT 3R R & Tt e o yehri
=1 ity hifsR

(A) a1 e

(B) a1 et

(C) sa1 Afaeym

(D) =1 &

MS-WORD # sedhete JRIT SIGIET il =
F % ford wrd fapen @

(A) Insert > Autotext > Formula

116.

(B) Table > Formula

(C) Format > Paragraph
(D) STk § § IS oft T

FeT13e ATE forehed w1 e S9am ®

(A) T3 I TEGfIT ST 3T ITASH FHIHT
TEd ©

(B) ¥et, B, fafyr 3w g St gloremadt
1 ITgAfd &

(C) ISl W TATEE hl T T hl A
ECl]

(D) IWIh Tt
DHC TS12-WM

117.

114.

115.

116.

117.
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Macros in MS-EXCEL may be best
described as follows

(A) Create graphics shortcut keys in
MS-EXCEL

(B) Small pieces of textual phrases

(C) Recording instructions in MS-EXCEL
or creating small programs to be
repeatedly played thru shortcut keys

(D) Playing pieces of text thru shortcuts

Defining constraints and rules regarding
the range and type of data that can be
inputted in a worksheet range in MS-
EXCEL is called

(A) Data Testing
(B) Data Control
(C) Data Validation
(D) Data Query

It is possible to calculate using formula in
MS-WORD using option

(A) Insert > Autotext > Formula

(B) Table > Formula

(C) Format > Paragraph

(D) None of the above

Handout Master option has the following
use

(A) Handouts of presentations that you
wish to make available

(B) Allows features like header, footer,
date and time

(C) Allows miniature presentation of
slides on paper

(D) All of the above
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118.

119.

120.

121.

122.

MS-EXCEL # iR foehca form oo s
R ST 2 ?

(A) ST foswo
(B) 31 ¥e & fotu 31am g1 Ufsawm
(C) a1 BRATT
(D) WifeTshi TueATati shi e

T, 3 IR BT ¥ g SR R 7
(A) 37 T

(B) 3T ST LT

(C) Te=Td HI AT

(D) “irmifers wrfes

e o AT | e e R
(A) SEa STHRRT G LT
(B) T UHIHE i Seal AT
(C) Ufthtew =it Tafan
(D) T&@E § 5 AN

IfE 3719 Telnet T FTP 1 ST o @ & I,
e G 3 & fo7u 3=aqm wa FAmfafaa
T g THg-Ht g ?

(A) TATRIH

(B) SsiexH

(C) &¥H (&)

(D) g@ur
Frfafad & 8 =-81 TCP/IP Tieiehid Teh
T € gl wRiH W Uftciee™ SR & foig

ST 91 o foTQ TfeeTeher s i Stgufa
e ?

(A) UDP
(B) VMTP
(C) X.25
(D) SMTP

DHC TS12-WM
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118.

119.

120.

121.

122.

Solver option in MS-EXCEL is used for
(A) Data Analysis
(B) Data prediction for different data sets
(C) Formatting of data

(D) Solving statistical problems

What is the main difference between
LAN’s, WAN’s and MAN's ?

(A) Their names
(B) Their Data rates
(C) Cost of setup

(D) Geographical coverage

Benefits of a network do not include
(A) Improved information sharing

(B) Better monitoring of
performance

worker

(C) Sharing of peripherals

(D) Low maintenance cost

If you use either Telnet or FTP, which is
the highest layer you are using to transmit
data ?

(A) Application
(B) Presentation
(C) Session
(D) Transport

Which of the following TCP/IP protocol
allows an application program on one
machine to send a datagram to an
application program on another machine ?

(A) UDP
(B) VMTP
(C) X.25
(D) SMTP
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123.

124.

125.

126.

127.

DHC TS12-WM

HigH ST o1gd 3T TJSTEAIR |
(A) 2T
(B) X

(C) R TETeX
(D) e (iwer) die

I qrfetert 1 3ed | R 7

(A) TS % T TGH I TR AT
(B) TIded UZH 1 Tdieh TIH SIaHT
(C) weash wE

(D) 7T o foTu werdt Freret WRt @isiT

0S| weash fehesrr #, Hare-fmo ik
TAA-TEed o fusteri R

(A) & (8¥F) TRR

(B) T I

(C) ghEdrE A

(D) ETaT foteh TR

{od TRET fen gt ®U T §

(A) TS FATEE T foreen

(B) 3eMe forem smenfia

(C) T (Wre) FeTse Hat fieen
(D) (B) ¥R (C)

frferfiaa & @ H-"1 WAN 2R & fog
JETIH © 7

(A) forst

(B) fem

(C) WX

(D) R

123.

124.

125.

126.

127.

-24-

A modem is connected in between a
telephone line and a

(A) network

(B) computer

(C) communication adapter
(D) serial port

What is the purpose of a routing table ?

(A) To store every address of every
node

(B) To know the exact location of
destination address

(C) To flood network

(D) To find most efficient route to the
destination

In OSI network architecture, the dialogue
control and token management are
responsibilities of OSI

(A) Session layer
(B) Network layer
(C) Transport layer
(D) Data link layer

Railway Reservation Systems are

basically
(A) simple client server systems
(B) intranet based systems
(C) fast distributed networked systems
(D) (B)and (C)

Which of the following is essential for WAN
hardware ?

(A) Bridge
(B) Switch
(C) Router
(D) Firewall
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128.  =hIET WIEHRIA Siiohel fSaTSd o SIEaRR Ud i
@IS o foTT S ferar STa 2 7
(A) RARP
(B) ARP
(C) IP
(D) ICMP
129. < rdTeATST SUANT A ol T Geleh © 7
(A) Faet T SISt TIH & 9 Thd ©
(B) =Afafih el i Stigd W T 2ot Sftheh
BN T I 5 ST
(C) =13 Hivt e
(D) Iga & &t Tfd & ST
130. TCP/IP ® Ui T forcm =
TS |
(A) 32
(B) 48
(C) 16
(D) IWIeh § 8 s off 7
131, fte o e H O aiE R SRRt | e
2 TeH % forg T TN BT R
(A) et s
(B) Rectew wreAl
(C) Tiers s =
(D) IWrad Teft
132. TafaRaa feamsat 4 @ fora &1 < frerg =0t
TR T oh ToTT I9T fohaT STt B, W@ ik
a9 oo fEem o 99 Wieishia 1 3T fomm
TR ?
(A) &= (B) fo=t
(C) s (D) fudfiex
DHC TS12-WM
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128.

129.

130.

131.

132.

What protocol is used to find the hardware
address of a local device ?

(A) RARP
(B) ARP
(C) IP
(D) ICMP

What is the drawback of using a BUS
topology ?
(A) Only apair of nodes can be connected

(B) Performance degrades as additional
computers are added or on heavy traffic

(C) There are no drawbacks

(D) Very slow data rates

Port address in TCP/IP is bits
long.

(A) 32

(B) 48

(C) 16

(D) None of the above

A remote batch-processing operation in
which data is solely input to a central
computer would require

(A) telegraph line

(B) simplex lines

(C) mixed bad channel
(D) all of the above

Which of the following device is used to
connect two systems, especially if the
systems use different protocols ?

(A) hub (B) bridge
(C) gateway (D) repeater
*
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133. HeM< HTEH 255.255.255.248 1 WM &k | 133.  How many hosts can be configured using

foheH Bl IR fohdl ST Hehd & 7 a subnet mask 255.255.255.248 ?
(A) 6 (A) 6

(B) 248 (B) 248

(C) 48 (C) 48

(D) 255 (D) 255

134. =99 WA 192.168.10.51 Je9e ID &1 fe&dm | 134.  What part of 192.168.10.51 is the Network

7, Tfi fepiee Teme ureh ? ID, assuming a default subnet mask ?
(A) 192 (A) 192

(B) 192.168.10 (B) 192.168.10

(C) 0.0.05 (C) 0.0.05

(D) 51 (D) 51

135. fF=fifaa @ sm-diafda deid @ v et | 135, Which of the following services use TCP ?

2t ) DHCP
i) SroEEd i) SMTP
i) THUARI iiy HTTP
i) TER iv) TFTP
iv) et v) FTP
v) THer (A) i) and ii)
(A) i) AT i) (B) i), iii) and v)
(B) ii), iii) 371 v) (C) i), ii) and iv)
(C) i), ii) AR iv) (D) i), iii) and iv)
(D) i), iii) 3R iv)
136. The first part of a complete URL is the
136. Fefle URL =T 98T 91T © i needed to access the web
A GETYHT ol TFEY o o HH A1 | resource.
(A) TS| (A) address
(B) H (B) name
(C) &ThIE (C) location
(D) eIkt (D) protocol
DHC TS12-WM 26- *
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137. XMLE “X" s i g 7
(A) Mixed

(B) Cross-platform
(C) Extensible

(D) Exclusive

138.  Web.config %Tsel o1 39T ferart STTaT ®

(A) 3G 10 R HIHR L ST Tl TS IS
foreTse Hieea wedrdn @

(B) A T =l IR A & forg

(C) A9 T3S ! HIHT L  foTg

(D) THAIHYA o 72 Tefiael SHEIE 3T
e SFTE R

ASP ¥ fewpice ferfedm w2 |
(A) EcmaScript

(B) VBScript

(C) PERL

139.

(D) JavaScript

T e fepte g =1 afom @ e ?
<script type=“text/javascript”
language =“javascript™

var gpt = new Array();

gpt[0] = “WebDevelopment”;

gpt[1] =“ApplicationDevelopment”
gpt[2] =“Testing”

gpt[3] = “QualityPointTechnologies”;
document.write(qpt[0, 1, 2, 3]);
</script>

(A) Tl

(B) QualityPointTechnologies

140.

(C) WebDevelopment

(D) Web Development, Application
Development, Testing, Quality Point
Technologies

DHC TS12-WM

137. What does the “X” in XML stand for ?
(A) Mixed
(B) Cross-platform
(C) Extensible
(D) Exclusive
138. Web.config file is used
(A) Configures the time that the server-
side code behind module is called
(B) To configure the web server
(C) To configure the web browser
(D) To store the global information and
variable definitions for the application
139. Default scripting language in ASP
(A) EcmaScript
(B) VBScript
(C) PERL
(D) JavaScript
140. Whatis the output of the below java script

code ?
<script type="text/javascript”
language ="javascript™>
var gpt = new Array();
gpt[0] = “WebDevelopment”;
gpt[1] =“ApplicationDevelopment”
gpt[2] =“Testing”
gpt[3] = “QualityPointTechnologies”;
document.write(qpt[0, 1, 2, 3]) ;
</script>
(A) Error
(B) QualityPointTechnologies
(C) WebDevelopment

(D) Web Development, Application
Development, Testing, Quality Point
Technologies
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141.

142.

143.

144,

DHC TS12-WM

TR gfeferfe s o, Farser ufee onfe
= UNIX OS ¥ & fireen sriaett § wufeq
ora ST B, 39 e B

(A) dev
(B) etc
(C) bin
(D) Usr

UNIX OS & foreen grer o gfeferdt s,
R CEA RIS IHE R E] IEENED]
FEUda e e |

(A) fom

(B) I

(C) WrwrEd

(D) @mife

3 AT ST T, S i SelTs A ST
1 = F o FoTT I -1 B FEATA TR
STt g ?

(A) GHre"

(B) Tusgcwm

(C) eizE 9fd 59

(D) ¥4

T8 H ey BI5ed i TURT A i
TfshaT o1 T hed & S ok 97 Sete W ast
g 9l ST Hd |

(A) S HEU0
(B) eI ifte
(C) foredfi

(D) EipHeTH

141.

142.

143.

144.

-28-

Executable utility programs, compilers
editors etc. are stored in UNIX OS in the

system directory called
(A) dev
(B) etc
(C) bin
(D) Usr

System data and utility programs,
password and login files in UNIX OS are

stored in directory.
(A) bin

(B) user

(C) profile

(D) etc

When creating a Web document, what
format is used to express an image’s height

and width ?
(A) Centimeters
(B) Pixels
(C) Dots per inch
(D) Inches

What is the process that condenses files
to be stored in less space and therefore,

sent faster over the Internet ?
(A) Data condensation
(B) Data compression
(C) Zipping

(D) Defragmentation
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145. <9 & g o 2 T 145. De Morgan’s law states

(A) XAYZXVV (A) XAYzivv
(B) Xvy =X Y (B) Xvy=X"Y
(C) Both

(C) Both
(D) None of these

(D) None of these
146. Truth table of Boolean function

146. Booleanfunction X.Y.Z+X.Y.Z + X.Y.Z+ X.Y XY.Z+XYZ+XY.Z+XY matches with
for o s R 7 (A) xry
€) z
B) Y
(D) None of these
C) z
(D) T A P T 147. Which of the following statement
represents commutative law ?
147. e FEfAfad oM commutative law ® 7 (A) (X+Y)+Z=X+(Y+2)
(A) X+Y)+Z=X+(Y+2) (B) X. (Y +2)=(X.Y)+(X.2)
(B) X. (Y +2) =(X.Y) +(X.Z) (C) X+Y=Y+X
(C) X+Y=Y+X (D) X+ X=X
(D) X+ X=X

(A) I IR TH H STa1-aaelt o
(B) &t I I U @ Fgaq @

(C) |ft U ol I ¥ Feaq |

(D) T+t I, TH TS . hl + T g &

(A) Interchanging all zero and ones only
(B) Changing all zero to one only
(C) Changing all ones to zero

(D) Interchanging all zero and ones and
.0+

149. Minterm Xm(L 3,5,6) f/H maxterm

S— 149. Minterm Xm(1 3,5, 6) equals to maxterm

(A) TIM(0, 3,7) (A) TIM(O, 3, 7)

(B) TIM(O, 2, 4, 7) () TIM(O0, 2,4, 7)

() TIM(O, 3, 4,7) (C) TIM(0,3,4,7)
(D) T & i e

DHC TS12-WM -29- *

(D) None of these
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150.

151.

152.

153.

154.

Toh AT (X + Y + 2).(X+ Y + 2)®
(A) SOP form
(B) POS form
(C) Standard POS form
(D) Standard SOP form

ot srfireafa
X+Y+2).(X+Y+2)(X+Z) BFE
ELRCIES I EICT R

(A) X+Y

(B) X+(Y+2)

(C) X+(Y+2)

(D) X+(Y+2)

T =R @ o Afveafad Ffta form s werar
g7

(A) 64

(B) 256

(C) 512

(D) 1024

TS dcd @IS h ht o8 Tl TATied
o dar ®

(A) O (n)

(B) O (log n)

(C) O (nlog n)

(D) T8 © g el

Quick sort =l Te® wameT [T q&rar feufa &
YR 8 T ST ashar @ 7

(A) R G fafy
(B) wgf=gshisnur
(C) gHadt fafyr

(D) T4 & IS T

DHC TS12-WM

150.

151.

152.

153.

154.

Thelogicexpression (X + Y + Z).(X + Y + Z)
is called

(A) SOP form

(B) POS form

(C) Standard POS form

(D) Standard SOP form

Boolean function
X+Y+2).(X+Y+2Z).(X+2Z) can be
minimized to

(A) X+Y

(B) X+(Y+2)
(C) X+(Y+2)
(D) X+(Y+2)

How many Boolean functions of three
variables are there ?

(A) 64

(B) 256
(C) 512
(D) 1024

Most effective algorithm which finds the
median of an unsorted, n size array would
take the time

(A) O (n)

(B) O (logn)

(C) O (nlog n)
(D) none of these

Worst case efficiency of quick sort over
an array having n items can be improved
by

(A) Non-recursive method

(B) Randomization

(C) Recursive method

(D) None of these
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155.

156.

157.

158.

159.

160.

foraa qoat &1 @1 91 HaAT ? array A
(-3:10, 5:12) ¥ 7
(A) 91
(C) 112

(B) 119
(D) 104

AT g1 &R array A [1:5,2:7]. 8 A[2][3] T
TAT HRIT BT SR SR U1 500 B 3R Iq@
Uferd STIERA T UTe TR ST ®

(A) 501 (B) 506
(C) 507 (D) 508

Stack ®

(A) Tfemm TRt G
(B) TIfcieh ATheT TLEAT
(C) Fferee ST GL=mT
(D) T8 & IS

ffuMu postfix AB*CD/+ =T prefix et
(A) +*AB/CD
(B) +A*B/CD
(C) +AB*C/D
(D) +AB*/CD

Queue 1 T T o felt SEATe TR ST Tehal
27

(A) STUHTE

(B) sfrupud

(C) e

(D) g&u
TR T&H queue  frontH=Ish %1 HH rear I
o SHISR B 4l queue

(A) @t 3

(B) Wi s

(C) W Fad TH & dcd B

(D) ® e dcd & TehelT 2

DHC TS12-WM

155.

156.

157.

158.

159.

160.

How many values can be held by an array
A (-3:10, 5:12) ?
(A) 91
(C) 112

(B) 119
(D) 104

Consider a two dimensional character
array A [1:5,2:7]. Assuming row major
order of storage determine the address of
element A[2][3] if base address is 500.

(A) 501 (B) 506
(C) 507 (D) 508
Stack is

(A) Static data structure
(B) Dynamic data structure
(C) Inbuilt data structure
(D) None of these

Find prefix of following postfix AB*CD/+
(A) +*AB/CD
(B) +A*B/CD
(C) +AB*C/D
(D) +AB*/CD

Queue can be used to implement
(A) DFS

(B) BFS

(C) Radix-Sort

(D) Recursion

In a queue if value of front pointer is equal
to rear pointer then queue

(A) Is empty
(B) Isfull
(C) Has one element

(D) May have one element
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